Windows 2008 running latest php and mysql

Million Dollar Script Forums Installation Windows 2008 running latest php and mysql

This topic contains 4 replies, has 2 voices, and was last updated by  Mark 5 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #687

    Mark
    Participant

    I installed and everything seemed to go ok but am getting this error (Unknown column ‘block_id’ in ‘field list’) in admin under main summary and this error (Unknown column ‘block_id’ in ‘field list’select block_id, status, user_id FROM blocks where banner_id=’1’) when i go to this link http://www.helplaunchmybusiness.com/users/order_pixels.php and this (Insert Into users(IP, SignupDate, FirstName, LastName, CompName, Username, Password, Email, Newsletter, Notification1, Notification2, Validated) values(‘65.170.239.79’, ‘2012-03-07 00:37:30’, ‘Mark’, ‘Galante’, ‘blablabla,inc’, ‘mertzdog’, ‘3ebb1d2eba8d9953409da871bea58243’, ‘Mark@TheGalantes.com’, ”, ”, ”, ‘0’)Field ‘Aboutme’ doesn’t have a default value) when i try to create a new user account. I’m thinking that something is messed up with the table (blocks). Can someone help me out here Please?

    Ok after starting from scratch and running install.php twice now since original install i get this error that i must not of noticed on first install:

    Error: BLOB/TEXT column ‘alt_text’ can’t have a default value(

    CREATE TABLE `blocks` (
    `block_id` int(11) NOT NULL default ‘0’,
    `user_id` int(11) default NULL,
    `status` set(‘reserved’,’sold’,’free’,’ordered’,’nfs’) NOT NULL default ”,
    `x` int(11) NOT NULL default ‘0’,
    `y` int(11) NOT NULL default ‘0’,
    `image_data` text NOT NULL,
    `url` varchar(255) NOT NULL default ”,
    `alt_text` text NOT NULL default ”,
    `file_name` varchar(255) NOT NULL default ”,
    `mime_type` varchar(100) NOT NULL default ”,
    `approved` set(‘Y’,’N’) NOT NULL default ”,
    `published` set(‘Y’,’N’) NOT NULL default ”,
    `currency` char(3) NOT NULL default ‘USD’,
    `order_id` int(11) NOT NULL default ‘0’,
    `price` float default NULL,
    `banner_id` int(11) NOT NULL default ‘1’,
    `ad_id` INT(11) NOT NULL default ‘0’,
    `click_count` INT NOT NULL,
    PRIMARY KEY (`block_id`,`banner_id`)
    ))

    41 Operations Completed.

    Database successfully Installed.

    Help please someone. Thanks in advance

    #699

    Ryan
    Keymaster

    What version of MySQL is that?

    It is possible the script won’t run properly on Windows. I haven’t tested the old version on Windows but I will try to make the newer ones run on it.

    #701

    Mark
    Participant

    Hey Ryan thanks for your reply. Wasn’t anything to do with windows and your script works fine on windows environment. As it turns out mysql 5 was the problem. Played with mysql a little and came up with the answer. If you run into this error again you can help the person who is getting the error by having them edit the my.ini file where they see this:

    # Set the SQL mode to strict
    sql-mode=”STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION”

    to this:

    # Set the SQL mode to strict
    sql-mode=””

    Apparently your script doesn’t like the fact that mysql 5 default install set this mode to strict

    #702

    Ryan
    Keymaster

    I am glad you got it working and thank you so much for letting me know =)

    #703

    Mark
    Participant

    also both the old and new versions of your scriptworked for me on windows. Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.