Forum breadcrumbs - You are here:ForumForum: Bug ReportsWhite page after log in
Login or register to post.

White page after log in

Hi Ryan!

First let me say that I am kind of a big fan now and I really appreciate that you provide all of that here - including your time and help!

I used your script and built a nice page together with a friend - we are no pros in webdesign but we know the basics πŸ˜‰

Now as we are almost finished we discovered a BIG problem :/

when we create a user and log in to the page the whole page gets white and nothing happens anymore, even not, if we "delete" everything in browser and go again to .../users => page is still white....and it happens mit explorer, chrome and safari (I tested just these 3)....

weird is that when I tried an ordering process (so uploading pixels and so on) and just logged in at the end of the ordering process it worked and i continued with the payment .... so it seems that just the "my account" thing - so the user page, does not work....

We would really really appreciate your help cause right now we are in that "all that work was for nothing" mood :/

I took screenshots if that maybe helps - but I dont find a way to upload them πŸ™‚

We use the newest version of the script and also the PHP version on the webspace is newest version....

Thanks a lot!!!!!!!

RegardsΒ 

Lukas

Hi there,

I'm glad you find it useful!

You can try to enable error logging in the Main Config by changing it to 32767

Then try to reproduce the white page and then check your web server's error logs. There may be error log files in the folders such as /users/error_log or something like that with new errors.

Ryan

Thank you for your very fast reply!!! πŸ™‚

To be honest....I don't know where to change that number?! I logged in to /admin and there I find Main Config but I have no idea where to change that....or do you mean in a certain php file?

I already wrote my hoster about the error log files, they don't provide it as a standard, I have to ask and they will send it to me.

Thanks πŸ™‚

Lukas

There is an Error Reporting option in the Main Config section near the bottom of the page in the middle of the Misc Settings section.

Thx, I found it in the end πŸ™‚

So I tried it two times in two different browsers and here is the error code:

Β 

[Wed May 16 22:12:54 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/favicon.ico, referer: http://www.XXX.com/[Wed May 16 22:12:54 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/error, referer: http://www.XXX.com/[Wed May 16 22:16:36 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/favicon.ico[Wed May 16 22:16:36 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/error/404-file-not-found.html[Wed May 16 22:16:39 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/favicon.ico[Wed May 16 22:16:39 2018] [error] [client 89.144.212.121] File does not exist: /home/.sites/50/site1699/web/error/404-file-not-found.html



Do you have an idea what the problem could be or why this is caused? :/
Thanks a lot!

Lukas

Hi,

Those errors seem to be unrelated. Did you enable error reporting in the main config and then try to reproduce the issue?

Ryan

Hi,

unfortunately I enabled error reporting but forgot to save πŸ˜€

Now as I did I have got the error lines and I could change the things that were the problem!

Thanks a lot for your willingness to help! I really appreciate it!

Have a great weekend!

Lukas

OK great! Were they related to issues in the script that I should fix or something else related to your hosting environment?

I had to change some lines in scripts - unfortunately I don't remember all of them but it was always the same and I remember one certain file:

In HTML.Purifier.autoload.php (in /vendor/ezyang/htmlpurifier/library) I had to change "__autoload" in line 17 to "spl_autoload_register" ....the error log told me exactly where to change - maybe like 4 lines in 4 files or so!

I don't know if this has to do with my hoster or php version or something else or if this is a mistake in the script - but if so, a lot of other people must have had the same problem before so I don't think so πŸ™‚

Thanks again!

Β 

Lukas

Hmm, that's odd. Do you know what version of PHP you're running? You can see if you go to the MDS admin under the System Info near the bottom left of the menu.

I've been testing it on PHP 7.2.5 but haven't had that issue and haven't had it happen on any other server or have any other reports of it yet. I know __autoload is deprecated in 7.2.x but the code in that file should work with PHP 7.2. Especially since it looks like they specifically updated that library for PHP 7.2. I suspect maybe you ran into some other issue but perhaps whatever you did forced it to use the legacy loader which somehow fixed it for you.

Furthermore, I would think that should have just been a deprecated function notice, not an error that would halt the execution of the script causing a white screen.