Warning Errors

Million Dollar Script Forums Installation Warning Errors

This topic contains 13 replies, has 2 voices, and was last updated by  Eliza 4 years, 4 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1063

    Eliza
    Participant

    Hi guys! I am a new user of the script. I have just finished installing it, deleted the install.php and moved on to the admin section. I add the password but keep getting warnings there and i’m not sure what i am doing wrong. Can someone help?
    This is what I get:

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/92/11054992/tmp/sess_4dtm06gk28r6n6rtjulg8mbmb5, O_RDWR) failed: No such file or directory (2) in /home/content/92/11054992/html/admin/admin_common.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cookie – headers already sent by (output started at /home/content/92/11054992/html/admin/admin_common.php:2) in /home/content/92/11054992/html/admin/admin_common.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/content/92/11054992/html/admin/admin_common.php:2) in /home/content/92/11054992/html/admin/admin_common.php on line 2
    Main Summary

    Current GMT Time: 2013-05-15 07:28:43
    0 Advertiser Accounts
    0 Orders Waiting
    0 Orders Cancelled
    0 Orders Completed
    0 Pixels Waiting for approval

    Warning: Unknown: open(/var/chroot/home/content/92/11054992/tmp/sess_4dtm06gk28r6n6rtjulg8mbmb5, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    Thanks!

    #1064

    Ryan
    Keymaster

    Hello,

    It looks like your tmp folder might not be writable by the web server user located here: /var/chroot/home/content/92/11054992/tmp

    Make sure that folder has write permissions for the user the web server is running under.

    #1065

    Eliza
    Participant

    Thanks for the quick reply! 🙂

    I changed the permissions and made sure that pixels and tmp (in admin) has write permissions for the web server as well.. I still get the same error though.. : Not sure if I’m doing something wrong..

    #1066

    Ryan
    Keymaster

    Hmm, well for whatever reason your web server user is unable to access this directory. /var/chroot/home/content/92/11054992/tmp/

    It may be a parent directory such as /var or /var/chroot or /var/chroot/home/content/92 which it doesn’t have access to view etc.

    It is the location of your PHP session folder and PHP is failing to start a session because it cannot access /var/chroot/home/content/92/11054992/tmp/ to create a session file there.

    #1067

    Eliza
    Participant

    Hmm.. After uploading the files and before installing the script, I have changed my os from windows to linux, because of some permission issues I had at go daddy. I got an email that the update took place, but it might need some time for new content to appear. Is there a chance that this is what messed things up? Should I maybe try re-installing?
    Thanks again for your time 🙂 I’m a newbie at this and I really don’t know what I am doing :p

    #1068

    Ryan
    Keymaster

    Well, in my experiences Godaddy is a horrible host and I often refuse to work on peoples websites if they don’t get off Godaddy and use some other host.

    Other then that I doubt reinstalling will do anything. Waiting likely isn’t going to do anything either. If you can’t adjust the permissions so that PHP can write to the tmp folder then all I could say is change your PHP session save path to somewhere else outside of your website root folder so it isn’t accessible from the internet and see if that helps. If you can even edit your PHP settings with Godaddy.

    #1069

    Eliza
    Participant

    Changing a host is not an option for me as i have already paid and will be losing my money. Go daddy might not be the best host but so far they have been willing to help me resolve any problems I had.
    Like I said, I am very new to this, but very willing to learn as well. I need help though. I am not able to see where this directory is: /var/chroot/home/content/92/11054992/tmp/
    Is it not the same as this one: webroot/admin/temp ?
    That is the one I am changing, using ftp file manager. Is there an other way to do it? Am I accessing the wrong files?

    #1070

    Ryan
    Keymaster

    No that isn’t the same folder. Your webroot is where your web files go that are accessible to the internet. PHP sessions should go in another folder. In this case that other folder does not appear to be writable by your PHP installation for whatever reason. Try putting this PHP script I just made into a file into your webroot folder. Name it test.php or whatever. Then go to yoursite.com/test.php

    [code]
    <?php
    $path = '/var/chroot/home/content/92/11054992/tmp/';

    // test creating a file
    if (!touch($path . 'testfile')) {
    echo 'Unable to create file…
    ‘;
    } else {
    echo ‘File was created successfully!
    ‘;
    }

    // test removing a file
    if (!unlink($path . ‘testfile’)) {
    echo ‘Unable to remove file…
    ‘;
    } else {
    echo ‘File was removed successfully!
    ‘;
    }
    ?>
    [/code]

    #1071

    Eliza
    Participant

    ok.. i did that and I’m getting similar problems:
    Warning: touch() [function.touch]: Unable to create file /var/chroot/home/content/92/11054992/tmp/testfile because No such file or directory in /home/content/92/11054992/html/test.php on line 5
    Unable to create file…

    Warning: unlink(/var/chroot/home/content/92/11054992/tmp/testfile) [function.unlink]: No such file or directory in /home/content/92/11054992/html/test.php on line 12
    Unable to remove file…

    So I need to figure out how to access my webroot and change the permissions.
    Thanks again for your time and help! I appreciate it!

    #1072

    Ryan
    Keymaster

    So basically it is like I said before. Your web server does not have access to that folder and that is where your PHP session save path is set to. You have to either change your PHP session save path in your php.ini settings or make sure that folder exists and is readable/writable by your web server. If you have any troubles doing this you should contact your host.

    #1073

    Eliza
    Participant

    Ok.. I contacted go daddy and the issue is resolved. It was indeed an issue with the permissions and it was due to the transition from windows to linux. Some file was not updated correctly. It’s almost all good now. Admin panel works perfectly and the example page looks good, but i do not have access to the main site. When I visit my actual website I get :
    Forbidden
    You don’t have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache Server at melissi.net Port 80

    I think it again has something to do with permissions and it must be on go daddy’s behalf as well. I ll see to it!
    Thanks again for your help and patience. The script is great!

    #1074

    Eliza
    Participant

    yeah.. that’s because I don’t have an index file :p Was there supposed to be one with the script or am I supposed to create it myself? 🙂

    #1076

    Ryan
    Keymaster

    You are using the old version (rather than development snapshot) so you would have to rename example.html to index.html as noted in the README.txt

    If you have any troubles try starting fresh and giving the development snapshot a try.

    #1077

    Eliza
    Participant

    yeap! I got it 🙂 Thanks for all your help! I ll try updating as well!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.