Strict Standards & Warnings

Million Dollar Script Forums Installation Strict Standards & Warnings

This topic contains 11 replies, has 2 voices, and was last updated by  Ryan 2 years, 10 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #2131

    main_body
    Participant

    Hi,
    Everytime I try to install the script, after the installation (install.php) comes the normal page telling me to delete install.php and so on.
    BUT with warnings like this:

    ‘Strict Standards: Declaration of smtp_message_class::SendMessageBody() should be compatible with email_message_class::SendMessageBody(&$data) in /home/yourpix/public_html/mail/smtp_message.php on line 594
    41 Operations Completed.’

    then I wanted to continue with the configuration and all I saw after putting in the ‘ok’ password was a page full of error messages and a small table.. (pls look at the attachment)

    Could you be so kind and HELP ME?
    I would appreciate it
    Thank you very much.

    Regards,
    main_body

    Attachments:
    You must be logged in to view attached files.
    #2135

    Ryan
    Keymaster

    You have your error reporting level set wrong in your php.ini. The messages shouldn’t really be there but they are more like warnings than errors. You should adjust your error reporting in your php.ini though to stop them from showing on a production site.

    More info: http://php.net/manual/en/errorfunc.configuration.php#ini.error-reporting

    #2136

    main_body
    Participant

    @ryan Thanks so much for helping me.
    Sorry, but I am kind of like a newbie in PHP programming but I want to add the script to my website with all its awesome features.
    So I have to ask you what is the php.ini/where can I find it and how exactly can I adjust my error reporting in it? Because I didn’t really understand the process described on php.net

    Kind Regards.

    #2137

    main_body
    Participant

    or better to ask: what should be the exact content of the php.ini file?
    (Script)

    #2138

    Ryan
    Keymaster

    The php.ini file is the config file for PHP. If you don’t understand how to configure it you should ask your web host.

    #2139

    main_body
    Participant

    I created the php.ini and uploaded it to the public_html/, public_html/admin/ & public_html/mail/ directories. BTW I tried writing the script of the php.ini in many ways (you can see one version in the attachment)
    It still shows the messages. I’m desperate at the moment.

    Attachments:
    You must be logged in to view attached files.
    #2141

    Ryan
    Keymaster

    That likely isn’t how to properly edit your php.ini.

    Are you using a dedicated server or VPS? If not does your host even allow you to modify your php.ini settings? If you’re on shared hosting you probably can’t, though some will actually provide you a way. You might be able to use the .htaccess file, assuming they use Apache for the web server and allow you to do it that way. Note that you may have to refresh or restart Apache for the changes to take effect.

    Either way, since you aren’t really sure, you should contact your host and ask them to set the error reporting to a proper production setting so you don’t get strict standards errors. If they don’t understand that and can’t do that for you then I would highly recommend getting a different host that knows what they’re doing.

    #2142

    main_body
    Participant

    I fixed the whole problem right now.
    I just opened the config.php and the install.php files and replaced the code on the second line:
    ‘error_reporting(E_ALL & ~E_NOTICE);
    with the following code:
    ‘error_reporting(E_ALL & ~E_NOTICE & ~E_WARNING & ~E_STRICT & ~E_DEPRECATED);’

    There are no warnings again, it works.

    Thank you for your support, I appreciate it.

    Kind Regards,
    main_body

    Attachments:
    You must be logged in to view attached files.
    #2146

    main_body
    Participant

    I found out that it works best with the following line of code that might has to be changed in the /config.php, admin/install.php & /admin/edit_config.php

    Use
    ‘error_reporting(0);’ instead of
    ‘error_reporting(E_ALL & ~E_NOTICE);’

    No more messages/warnings/… are showing up so far so my first issue is fixed right now.
    Btw I currently have another issue. Please have a look at my new forum topic (Installation/SQL Syntax Error).

    Thank you.

    #2149

    main_body
    Participant

    Now, after editing the main config and after saving changes, the warnings show up again (the saved changes work for the example.html file though, but it mainly doesn’t work properly (most functions are not working))
    Only after saving the new MAIN CONFIGS, the warnings show up again.

    Let me try to explain this:
    When my own new main configs are saved, the warnings show up, even in the example.html file (the saved changes work for the example file tho) then > I edit the files switching the lines of code given above to deny those warnings:
    either from
    ‘error_reporting(0);’ to
    ‘error_reporting(E_ALL & ~E_NOTICE & ~E_WARNING & ~E_STRICT & ~E_DEPRECATED);’ or vice versa
    (both work to prevent the warnings from showing up)
    BUT THEN > the default main configs are set again when opening up the example.html file.

    so it’s like an endless loop:

    my own configs are set by me >> warnings show up >> I’m replacing the error_reporting code to hide the warnings again >> warnings are hidden BUT(!) the main configs are set to default >> I’m setting my own main configs (> repeat from the top)

    Is there maybe a way to set the main configs manually? Or do you have another idea to fix this issue completely?

    #2160

    main_body
    Participant

    Fixed completely by using the development snapshot (Y)

    #2165

    Ryan
    Keymaster

    I added a config option to modify the error reporting in the dev snapshot. I also did some other things such as convert it all to use mysqli and fix some of the notices (still a bunch more to fix) and hopefully fixed the currency symbols.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.