Favourite Host

RunCloud (free 5 day trial)

Install Service

Premium Support


Forum breadcrumbs - You are here:ForumForum: Bug ReportsOnMouseOver is not working
Login or register to post.

OnMouseOver is not working

Hello RyanI sent you an email some days ago, but i will post here too, maybe it can help others if they experience the same issue.I tried to changed the TEXT AD field from 'Text Field' to 'Text Editor' and 'HTML Editor' but with both options it happened that the 'onmouseover' function that should display a window with the text, image and URL doesnt work anymore for the pixels with longer texts.I tried processing the grid after doing the changes, and adding a new test pixels to check but nothing changes, its not working at all.Something else i noticed, when im logged as customer and i go to Manage My Pixels, after editing the pixels, below this appear the grid as a kind of preview, and there the mouseover thing works (image is not being displayed but the longer text works), but in the front end index page it doesnt.In the email i sent you some days ago i included the login info for the customer account with priviledges in case you would need to give it a look.Regards and thanks in advance.

To save some time i would like to add that i re-uploaded the /overlib/ folder in ASCII mode as its explained in this other thread:https://milliondollarscript.com/forum/2-bug-reports/286-mouse-over-boxBut it's still not working.

Hello,Thanks for the report! I will have to test out the text editor and see how it goes. I think I was going to update it to use CKeditor but I haven't tested it yet. It may be some other issue going on by the sounds of it. I will have to make a bug report for it and see if I can fix it when I get a chance. I am not sure exactly when that will be but maybe I can get to it before the end of the month if all goes well.Ryan

Hi Ryan, thanks for taking the time to check on this, i will try to add as much info as possible to colaborate with you. I would like to point again that the problem happens with both options "text editor" and "html editor" so unless the editor is the same the problem may be somewhere else.I just made 2 tests to elaborate a bit more about the issue:[b][u]Case 1:[/u][/b] Field set as: HTML EDITORText Writen: 1 line "test text to check the html editor behavior"http://img191.imageshack.us/img191/787/rep1p.jpgBehavior: In the screenshot you can see the "alt=" and the "/> that shouldnt appear, they are appearing in the publisher interface. And something else i want to point is that i underlined some words and its not appearing undelined. But, [b]in the index.html page i can see the onmouseover window[/b], not the underline but the text pretty much as i wrote it.[b][u]Case 2:[/u][/b] Field set as: HTML EDITORText Writen: 3 lines http://img717.imageshack.us/img717/7849/rep2d.jpgBehavior: the same "alt=" code things, same underline not working issue, but in this case [b]in the index.html the onmouseover window doesnt work[/b].So, for some reason the onmouseover window is not appearing when you write more than 1 line of text and the field is set to "text editor" or "html editor".I hope it can helps you to at least narrow a bit what to check.Cheers

Just a work around i found, it doesn't fix the problem, but i think it can help to find it.In the dynamic_forms.php file i commented this lines[code]case "ALT_TEXT":return true;[/code]to be able to remove the field, then i removed it, and created a new html editor field, edited the template to remove the old one and add the new one, and it is working as expected.Even tho, there are some issues, since the ALT_TEXT is missing:I'm getting message "Configuration error: Failed to bind the "ALT_TEXT" Template Tag. (not defined)" in the publisher interface after i edit something.And in the "your pixels" grid in the publisher interface i have the "date" "link" "pixels" "expires" "status" rows, but not the text row.So i think that the problem is not in the editor, but its a problem with this field name in particular, unfortunally i tried to read the script but im not a coder and its too long, so couldn't fix it.