Favourite Host

RunCloud (free 5 day trial)

Install Service

Premium Support

Forums

Login or register to post.

mysql is not compatible with the latest PHP

12

Hi,'mysql' is not compatible with the latest PHP (it's deprecated). You have to use 'mysqli' or 'PDO'.Without the change this script will be unusable very very soon.

Ahh yes, it shouldn't be that hard to fix so I can adjust the code.I've created an issue here where I'll post an update once it's done: https://github.com/MillionDollarScript/MillionDollarScript/issues/20

Hi there,I updated the issue with a link to the commit that converts everything from mysql to mysqli.

Probably not a easy as at first hoped. I implemented the new code and now my site does not load at all.Did you test it?

Do you get any errors in your logs?

Oh nevermind, I see what I did. Will fix it up.

There, hopefully that does the trick. I forgot to add the extra database connection parameters for mysqli commands.I also have added an option to change the Error reporting value and fixed the currency symbols.

Now the admin section is gaped wide open! No login asked for at all -no security -straight into Admin. You cannot log out of admin either!Hence, I shut down my site and removed the config file until this is fixed.Also shouldn't the admin login ask for a username too? Without it, this script is an open house for dictionary brute-force attacks.Are you not able to test it because of some extenuating circumstance?let me know, and I'll setup something off-site to test new builds.

Sorry, that was due to the solving of some of the notices that I had did. I pushed a fix for that.Yeah I know the login sucks but that's how it was before I started development on it and I'm not messing with it in this version. The WordPress plugin should fix that though once it's done.I do some testing when I get time. I didn't notice the admin login not working though since I was already logged in.Thanks for reporting the issues!

I've been testing it for a while now, and have found no problems so far.But I would suggest, if you haven't already, you should recommend in the installation instructions, to remove 'install.php' in admin folder after install, or else the site is wide open for attack.Good Job Ryan!

12