Favourite Host

RunCloud (free 5 day trial)

Install Service

Premium Support


Forum breadcrumbs - You are here:ForumForum: Bug ReportsI have many questions
Login or register to post.

I have many questions


In first time I want to say you a big thanx for your script and i want to say you sorry for my bad english.Well these are my problems:[color=#0044ff]1) When I go on "Map of Order", nothing appears:[/color](image screen.jpg)I don't know where is the problem =([color=#0044ff]2) The map's background is black and I don't know how to show my grid:[/color](image screen2.jpg)[color=#0044ff]3) Images uploaded was not resizing on the map.[/color]My PHP version is 5.2.17Sorry for all these questions and thank you again for your script that will surely allow me to finance my studies.Cordially,Gaëtan.


Does your PHP have the GD extension enabled? Do you get any errors in your web servers error logs?

Thank you for your rapidity, I'm on Host Mutualist 1and1 and I don't know how to view server's logs. In the admin panel, I have these informations:[quote]System infoYou have PHP version: 5.2.17GD Library version:Array( [GD Version] => bundled (2.0.34 compatible) [FreeType Support] => 1 [FreeType Linkage] => with freetype [T1Lib Support] => [GIF Read Support] => 1 [GIF Create Support] => 1 [JPG Support] => 1 [PNG Support] => 1 [WBMP Support] => 1 [XPM Support] => [XBM Support] => 1 [JIS-mapped Japanese Font Support] => )[/quote]

Well I am not familiar with 1and1 (I hear they are terrible) but maybe some folders aren't writable or something. There was a report here about black images: https://milliondollarscript.com/installation/documentation/docs#comment-41

I don't have this problem in admin area, all folders are writable... before there was not the black background but I certainly made a mistake.edit: I have an error when I click on "view pixels" in pixels admin:"The image "http://the-wall.fr/admin/show_map.php?user_id=1&BID=1" can not be displayed because it contains errors."The problem is probably here.

Hmm, I think you have to figure out whats in the error logs for your web server. Maybe PHP is running out of memory or something. You could try raising the memory limit in the Main Config.

I'm already at 64 MB, I also noticed that the PNG conversion does not work and that the JPG conversion did not display images. All this may be linked.I find server's logs but I don't know what should I watch.[u]edit:[/u]1and1 does not provide access to apache logs errors for shared hosting customers, they are simply a piece of code to generate our own errors logs. I'll try that and I'll keep you informed. Thank you again

Here is the error_log generated:[code]18 Feb 2011 23:54:06,"/homepages/0/d224845791/htdocs/wall/test/config.php: 127","(Notice) Undefined variable: DB_ERROR"18 Feb 2011 23:54:06,"/homepages/0/d224845791/htdocs/wall/test/lang/lang.php: 24","(Notice) Undefined index: lang"18 Feb 2011 23:54:06,"/homepages/0/d224845791/htdocs/wall/test/lang/lang.php: 44","(Notice) Undefined variable: _SESSION"18 Feb 2011 23:54:06,"/homepages/0/d224845791/htdocs/wall/test/lang/lang.php: 47","(Notice) Undefined index: MDS_SAVED_LANG"18 Feb 2011 23:54:06,"/homepages/0/d224845791/htdocs/wall/test/mail/smtp_message.php: 594","() Declaration of smtp_message_class::SendMessageBody() should be compatible with that of email_message_class::SendMessageBody()"[/code]

It looks like maybe the error reporting is messing it up or something. Set your error reporting to off. Those errors should be just harmless notices. However, if they are causing problems you might have to turn off the error reporting somehow. I have no idea how to do this on 1and1.

FYI, this is the error reporting I am referring to. It is in the php.ini. You can also sometimes set it in the php file itself (I think it might even be set in MDS, I can't remember) and sometimes the htaccess.http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-reportingAlso reference for the SMTP error from the mail lib being used in the script: http://www.phpclasses.org/discuss/package/9/thread/75/