Favourite Host

FastComet

Install Service

Premium Support

Forums

Login or register to post.

Fatal error: Uncaught Error: Call to undefined function mysql_connect

Hi,

I followed the guide several times, but unfortunately I can not upload files to the root directory of my site.
I can only put it in the htdocs subfolder.
I put all the permits and I try to go up
http://www.mywebsite.com/htdocs/admin/install.php and I get a file not found error

I also tried with http://www.mywebsite.com/admin/install.php (the files still remain under the root / htdocs / ...)
and I have this error

[code]Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/mhd-01/www.mywebsite.com/htdocs/config.php:121 Stack trace: #0 /home/mhd-01/www.mywebsite.com/htdocs/admin/install.php(29): require() #1 {main} thrown in /home/mhd-01/www.mmywebsite.com/htdocs/config.php on line 121[/code]

Maybe the 2.0 script is not suitable and I have to try the first version?

Thank you

Your htdocs folder should be the root of your site. So you should just have to go to https://example.com and it should automatically update the config and redirect you through the install process. That is if you're using the latest 2.1 development version and not 2.0.15.

The mysql error is likely that you are indeed using 2.0 instead of 2.1 since mysql was all changed to mysqli.

Make sure you download the version from this website. The big blue button on the right. Or click here: https://milliondollarscript.com/download/million-dollar-script/

Ok Perfect, now I try, thanks for the quick reply!

The script works! But there is a problem: after I saved the information on Main config remains the text Update config for several minutes and I would like to understand how many minutes I have to wait.

Also I can not find this area in my database phpMyAdmin

You shouldn't have to wait more than a second. Something might not be setup properly somewhere. You can try enabling the error_reporting line in the config.php at the top by setting it to error_reporting(24567);

Then try to reproduce your issue and check your web server error logs for any errors.

I'm not too sure what you mean about your database. What's the issue you're having with it?

I "solved" sorry.
Continue to remain in  "update config ", but the configurations are inserted equally.

At the moment until I change provider I can not change the privileges of users in the database, is a restriction of who provides me the hosting.
I would like to understand where I find that screen I posted in the previous post, I found the image in the tutorial for those who install on Yahoo (I'm not on Yahoo, but I assume it is on every phpmyadmin).

Yes the updating config message is normal. If it's saving your config properly then it should be fine.

You should be able to find out your database name, database user and host from your host. In fact if you're saving the config I'm guessing you already have it and have already installed the script so shouldn't have to worry about it. If everything is working fine then it should be ok. If you can't change your privileges and things are working ok then you're probably fine. Especially if you already have it installed. If you're getting errors somewhere just let me know what they are and I'll see if I can help.

A lot of this stuff is quite old and not created by me originally including that updating config message and a lot of the documentation which may be outdated. I'll update the documentation after the new version comes out.

I took over development of this software a number of years ago, I'm not the original creator of it but I have made countless changes and bug fixes. I'm working on a WordPress plugin version that will be integrated with WooCommerce but it's not ready yet. It's taking way too long but I'm still making progress.