fsockopen() function is disabled on this server

Million Dollar Script Forums Installation fsockopen() function is disabled on this server

This topic contains 7 replies, has 2 voices, and was last updated by  Fil 5 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #716

    Fil
    Participant

    Hi,
    when I want to configure Payment Modules I get this:
    fsockopen() function is disabled on this server.
    Support of my hosting says it is allowed and function_exists(‘fsockopen’) returns true. Phpinfo() shows allow_url_fopen is On but allow_url_include is Off. Might it be the problem? Or something else? Does anybody know solution? Thanks.

    #726

    Ryan
    Keymaster

    Is this when you try to configure the Paypal processor module?

    Try putting this in a PHP file and visit the file in your browser and let me know what it says:

    [code]<?php

    if( function_exists('fsockopen') ) {
    echo "

    fsockopen exists.

    “;
    } else {
    echo “

    fsockopen does not exist.

    “;
    }

    if (stristr(ini_get(‘disable_functions’), “fsockopen”)) {
    echo “

    fsockopen is disabled.

    “;
    } else {
    echo “

    fsockopen is enabled.

    “;
    }[/code]

    #728

    Fil
    Participant

    Hi Ryan,
    it is when I click to Paypal Module item in Configuration menu in administration. I put the code to php file and launched. I received this:

    fsockopen exists.

    fsockopen is disabled.

    #730

    Ryan
    Keymaster

    Hmm, odd.

    Try removing these lines 84-87 in /payments/paypalIPN.php

    [code] if (stristr(ini_get(‘disable_functions’), “fsockopen”)) {
    pp_mail_error ( “

    fsockopen is disabled on this server, this script can not post information to the PayPal server for IPN confirmation.”);
    die();
    }
    [/code]

    #731

    Fil
    Participant

    Hi Ryan,
    unfortunately nothing changes. I haven’t said yet everytime I click on Paypal Module item I receive also this e-mail message:

    fsockopen is disabled on this server, this script can not post information to the nochex server for IPN confirmation.

    Thanks, Filip

    #732

    Fil
    Participant

    … and also in Main Config in Misc Settings there is no radio button selected within “Use PayPal Subscription features?” item. Also there is no button selected there even when I choose one and save configuration.
    Fil

    #733

    Ryan
    Keymaster

    Try deleting this from /payment/nochexAPC.php lines 62-66:

    [code]if (stristr(ini_get(‘disable_functions’), “fsockopen”)) {
    nc_mail_error ( “

    fsockopen is disabled on this server, this script can not post information to the nochex server for IPN confirmation.”);
    echo “fsockopen() function is disabled on this server.”;
    die();
    }[/code]

    #734

    Fil
    Participant

    Hi Ryan,
    Great! Now it looks good!
    Thank you very much, Fil

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.